Forums Help & support inflating : invalid block type when trying to decrypt

This topic contains 2 replies, has 2 voices, and was last updated by  Prabhukumar R 1 year, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #27814 Reply



    I have tried to decrypt files that i had encrypted some months ago on a disk but I have a problem with some of them.

    I have the error : inflating : invalid bloc type.

    Looking around on the forum, I found this :

    AxCrypt app does have a verify file functionality in the latest version. You can use the same to verify the file structure.

    First, you have to enable debug menu to use the verify file functionality via File | Options | enable Debug.

    Then use the Check File submenu from the Debug menu to verify the file structure.

    You can also try the Try Broken File submenu from the Debug menu, to recover the corrupted file.

    So I tried it. The result is as below (i can’t upload the image, your site returns an error):

    MagicGuid OK with length 0

    Preamble Ok with length 16

    AxCrypt version 2.0.0. File format version 4.0

    V2KeyWrap Ok with length 248

    V2AsymmetricKeyWrap Ok with length 512

    AsymmetricRecipients Ok with length  1015

    FileInfo Ok with length 32

    Compression Ok with length 1

    UnicodeFileNameInfo Ok with length 256

    AlgorithmVerifier Ok with length 32

    Data Ok with length 8

    Unexpected header block type 176


    Thanks for your help.


    #27830 Reply


    My problem is the file was fine, as all the others. Then I encrypted them, left them on a disk that has not been used and now I can’t decrypt it. I don’t see how on of the thousand file would have been “damaged” except during encryption.

    #28405 Reply

    Prabhukumar R

    Hello GosuPaper,

    Apologies for the delayed response.

    We are checked your encrypted file structure report(that you have sent previously). in your files, data is corrupted/damaged. we think, your files are securely deleted or recovered files from any recovery tools. so your files are corrupted.

    If the file is damaged/corrupted then AxCrypt will not able to decrypt the same.

    If the above doesn’t help, please write an email to our support team

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: inflating : invalid block type when trying to decrypt
Your information: