Forums Bugs & issues AxCrypt freezes then reports "A task was canceled" repeatedly

This topic contains 1 reply, has 2 voices, and was last updated by  Svante 7 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #3361 Reply

    Taylor Wilson

    I have used AxCrypt for several weeks with no issues. For the last couple of days, when I launch AxCrypt (including after a full system restart), the app window will come up with a busy cursor, and it will stay in that state for several seconds, then report “An unexpected error ‘A task was canceled.’ ocurred” in a pop-up dialog. Hitting OK in the dialog puts the app back in the same busy/waiting state, and several seconds later it reports the same error with the same popup. As far as I know, that pattern repeats forever.

    I tried removing all the TXT files in the %appdata%/AxCrypt folder. After doing this, it prompts for my email address, then goes into that same frozen wait state. I’m unable to get past that.

    I am using AxCrypt 2.1.1388.0

    Thank you in advance for any help you can offer. I have used AxCrypt to encrypt some critical documents that we need to regain access to, so anything that can be done to resolve this issue quickly would be greatly appreciated.

    #3379 Reply



    First of all, please update your version of AxCrypt! I think you may be experiencing two different issues.

    However, I’m very interested to know if you’ve seen the ‘A Task has been cancelled’ error earlier than the last 24 hours?

    The following is a copy of the response I’ve used in some other threads here about the issue during the night:

    Ok, support is awake (actually we have been since 5 AM UTC this morning, working with analyzing the issue).

    Everything should be ok now, but here’s the full disclosure on what happened, and what’s happening.

    At around midnight UTC this night something went south with our main server. We do not yet know the exact mechanism, but we have found no indication that it was the result of an external agency or attack.

    Now, AxCrypt does not need to talk to our servers once initialized on a device. So, why did this cause problems for you?

    One user figured it out – it worked if you disconnect from Internet during sign in.

    AxCrypt does not need the servers, but tries to connect. What happened with our server was that it went into twilight mode, neither dead nor alive. It responded to requests, but never completed the response leaving the client hanging.

    AxCrypt does not properly handle this situation of answer-but-no-response. That’s a bug. We’ll fix it. We’ll also add an explicit offline mode, so you don’t need to mess with the Internet connection.

    Finally, we’ll be investigating and working on the server side issue until it no longer can happen again.

    My sincere apologies for the inconvenience, and perhaps some scary moments.

    Best regards,


Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: AxCrypt freezes then reports "A task was canceled" repeatedly
Your information: